Install the Prismic command line interface

Beta

These docs rely on Slice Machine, which is in active development and subject to change. Content Relationships are not currently supported with Slices.

When installing the Prismic CLI, if you haven't already, you will need to make sure you're using that latest version. Launch the terminal (command prompt or similar on Windows) and run the following command.

  • npm
  • yarn
Copy
npm install -g prismic-cli@3.8.3-beta.0
Copy
yarn global add prismic-cli@3.8.3-beta.0

Sudo command

Sometimes it's possible that a global (-g) command like this doesn't work because of permission levels on your machine. If that's the case for you, try executing a the sudo command below:

  • npm
  • yarn
Copy
sudo npm install -g prismic-cli@3.8.3-beta.0
Copy
sudo yarn global add prismic-cli@3.8.3-beta.0

Once you've ran the command you can confirm if your are using the correct version by running the following command:

Copy
prismic --version

You want to see the latest version released on npm. If you run in to any problems try uninstalling and reinstalling the CLI.